Mosquito Helicopter Forums
Problem with my ignition on my Air - Printable Version

+- Mosquito Helicopter Forums (http://forum.mosquito-helicopter.info)
+-- Forum: General Discussion (http://forum.mosquito-helicopter.info/forumdisplay.php?fid=69)
+--- Forum: General Discussion (http://forum.mosquito-helicopter.info/forumdisplay.php?fid=11)
+--- Thread: Problem with my ignition on my Air (/showthread.php?tid=7666)



Problem with my ignition on my Air - OkieAir - 07-23-2017

Guys,

I am having trouble with one coils in my ignition. One day one side just stopped firing.  I have verified both coils are good.  My grounds are good.  I have 2 good cdi's.  I have replaced my voltage reg. and my toggle switch up front.  I have trouble shot this down to what I think is the wiring harness but when I pull it all apart nothing is loose and it looks ok.  This aircraft has worked great for a while.  I'm sure it something easy but I am completely stumped.  Any ideas.  BTW everything is working on the aircraft except for one set of plug wires

I also need a detailed wiring diagram for the whole aircraft.  I looked all on the forum but didn't find what I was looking for.  Can anyone point me in the right direction.

Thanks everyone for your help


RE: Problem with my ignition on my Air - Chuck308 - 07-24-2017

what engine do you have ?


RE: Problem with my ignition on my Air - marcher07 - 07-27-2017

the 202 and he found the issue - a bad magnetic pickup


RE: Problem with my ignition on my Air - Chandlerede - 08-06-2017

I had a similar issue with my Hirth engine. I finally found that there was a bad connection in the coil and one tab broke off in my hand. Replaced the coil and problem solved. Good luck!