Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Duel rotor/engine tach problem.
#1
Hi all,
I have a MZ202 with a westach duel tach. The other morning i started the mosquito up and found that the engine side of the tach wasn't working. I checked continuity on the wires and changed a couple wire plugs. Everything seemed to be ok but still no movement of the tach needle. I read where you can change the two wires going to the gen (alt) and i did and the tach is working but with a little lower reading. I know something still isn't right and want to fix it before i fly it. I"m thinking it's the regulator or the gen. Is there anyone that can help me with this problem?
Thanks,
Loel
Reply
#2
Loel
I started flying my XEL in April 2009. At that time the Westach   # 3DA5-TC199-1P2 rotor & eng percent was what they installed at the factory. I went thru 2 analog gauges before I had one work for years till I sold the helo.  Unless your good at checking out wiring and don't find a reason It being erratic there is a good chance its bad. How many hours are on the gauge? my self and two others mosquito pilots did not want to go to the MGL rotor and eng percent only because of the MGL had no color face and we were used to that. I was told by westach that a company in Australia called Digillin was working on getting a Digital gauge,to work with the202. It looks just like the analog  gauge. I have one still in the box and the instructions of how to hook it up. It is for sale. If interested P/M me.

Good luck, Leo....
Reply
#3
check you have a good ground off the blue wire, then check see if you can influence it by adjusting the sensitivity on the back of the gage - there's a wire diagram in the manual,
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)